This content requires the base game War for the Overworld on Steam in order to play.

All Reviews:
Positive (14) - 100% of the 14 user reviews for this game are positive.
Release Date:
May 10, 2017
Developer:

Sign in to add this item to your wishlist, follow it, or mark it as not interested

Downloadable Content

This content requires the base game War for the Overworld on Steam in order to play.

Buy War for the Overworld - The Cynical Imp (Charity DLC)

Buy War for the Overworld - Kickstarter Theme Bundle (Charity DLC)

Buy War for the Overworld - Founders Theme Bundle (Charity DLC)

 

GamesAid Digital for Good

100% of all Brightrock Games proceeds will be donated to charity as part of the GamesAid Digital for Good initiative.

About This Content

Your Workers have formed the National Union of Dungeon Excavators. Their leader, The Cynical Imp, is unhappy to say the least about your slap-heavy working conditions and uncharitable procedures. He’s come out of retirement to head this campaign and is threatening an all-out strike unless you agree to his terms.



To download The Cynical Imp skin simply select your bundle. Larger donations will also grant access to the previously-exclusive Kickstarter and Founders Dungeon Themes!



The Cynical Imp will then hit the campaign trail across all non-Campaign game modes!

100% of all Brightrock Games proceeds will be donated to charity as part of the GamesAid Digital for Good initiative.

System Requirements

Windows
Mac OS X
SteamOS + Linux
    Minimum:
    • OS: Windows 7 Service Pack 1 , Windows 8 , Windows 10
    • Processor: Dual Core CPU @ 2.5GHz
    • Memory: 4GB RAM
    • Graphics: Nvidia GT450 512MB or better, ATI 4870HD 512MB or better
    • G3D Mark: 1500
    • Hard Drive: 7GB available space
    • Sound: Speakers or headphones

    Full Knowledgebase Article
    Recommended:
    • OS: Windows 7 (64-bit) Service Pack 1, Windows 8 (64-bit), Windows 10 (64-bit)
    • Processor: Quad Core CPU @ 2.5GHz
    • Memory: 8GB RAM
    • Graphics: Nvidia GTX 560 1GB RAM or better, Radeon 8950 HD 1GB or better
    • G3D Mark: 3000
    • Hard Drive: 10GB available space
    • Sound: Speakers or headphones

    Full Knowledgebase Article
    Minimum:
    • OS: OS X 10.10 or higher
    • Processor: Dual Core CPU @ 2.5GHz
    • Memory: 4GB RAM
    • Graphics: Nvidia GT450 512MB or better, ATI 4870HD 512MB or better
    • G3D Mark: 1500
    • Hard Drive: 7GB available space
    • Sound: Speakers or headphones

    Full Knowledgebase Article

    Due to compatibility issues, 2017 Macbook Pros and onwards which feature Intel Iris graphics are not supported. For more information please view our full article above.
    Recommended:
    • OS: OS X 10.6 or higher
    • Processor: Quad Core CPU @ 2.5GHz
    • Memory: 8GB RAM
    • Graphics: Nvidia GTX 560 series with 1GB RAM or better, Radeon 8950 HD with 1GB RAM or better
    • G3D Mark: 3000
    • Hard Drive: 10GB available space (may increase in the future)
    • Sound: Speakers or headphones

    Full Knowledgebase Article

    Due to compatibility issues, 2017 Macbook Pros and onwards which feature Intel Iris graphics are not supported. For more information please view our full article above.
    Minimum:
    • OS: Ubuntu 12.04 or higher
    • Processor: Dual Core CPU @ 2.5GHz
    • Memory: 4GB RAM
    • Graphics: Nvidia GT450 512MB or better, ATI 4870HD 512MB or better
    • G3D Mark: 1500
    • Hard Drive: 7GB available space
    • Sound: Speakers or headphones
    • Additional Linux Requirements:
      • glibc 2.14 or later
      • libstdc++6 or later
      • GCC 4.9 or later
      • Only the latest video card drivers are supported
      • OpenGL 3.0 support is required

    Full Knowledgebase Article
    Recommended:
    • OS: Ubuntu 16.04 or higher
    • Processor: Quad Core CPU @ 2.5GHz
    • Memory: 8GB RAM
    • Graphics: Nvidia GTX 560 1GB or better, Radeon 8950 HD 1GB or better
    • G3D Mark: 3000
    • Hard Drive: 10GB available space
    • Sound: Speakers or headphones
    • Additional Linux Requirements:
      • glibc 2.14 or later
      • libstdc++6 or later
      • GCC 4.9 or later
      • Only the latest video card drivers are supported
      • OpenGL 3.0 support is required

    Full Knowledgebase Article

More DLCs from this game

Customer reviews

Review Type


Purchase Type


Language


Date Range
To view reviews within a date range, please click and drag a selection on a graph above or click on a specific bar.

Show graph



Display As:
Show graph
 
Hide graph
 
Filters
Excluding Off-topic Review Activity
Playtime:
Loading reviews...