Featured Items
Games
Software Demos Recommended News

This content requires the base game Train Simulator 2014 on Steam in order to play.

Release Date: Aug 16, 2012
Popular user-defined tags for this product:

Downloadable Content

This content requires the base game Train Simulator 2014 on Steam in order to play.

Buy LNER A1 Tornado Add-On

$19.99

About the Game

The world-famous A1 Tornado is a favourite of train fans around the world, and you can proudly drive this fantastic locomotive yourself in Train Simulator.


Designed by Arthur H Peppercorn, of the London & North Eastern Railway (LNER). They were the last in a line of famous express passenger steam locomotives for the East Coast Main Line. The original 49 Peppercorn Class A1s were built at Doncaster and Darlington for British Railways at the end of the 1940s. However, the rapid onset of dieselisation in the 1960s meant that all were scrapped, after a life of only 15 years.


The A1 Steam Locomotive Trust, founded in 1990, built a completely new 'A1' to the original design and with the help of the latest technology. Fitted with additional water capacity and the latest railway safety electronics, Tornado is fully equipped for today’s main line railway. The Tornado add-on for Train Simulator is a wonderful recreation of this much-loved locomotive and is perfect for creating your ideal steam rail tour.

Includes

  • Peppercorn A1 Tornado Steam Locomotive in LNER Apple Green with British Railways insignia
  • Brake 1st Corridor in All Maroon
  • First Corridor in All Maroon
  • First Corridor in Crimson & Cream

System Requirements

    Minimum:
    • OS:Windows® XP / Vista / 7 / 8
    • Processor:Processor: 2.8 GHz Core 2 Duo (3.2 GHz Core 2 Duo recommended), AMD Athlon MP (multiprocessor variant or comparable processors)
    • Memory:2 GB RAM
    • Graphics:512 MB with Pixel Shader 3.0 (AGP PCIe only)
    • DirectX®:9.0c
    • Hard Drive:6 GB HD space
    • Sound:Direct X 9.0c compatible
    • Other Requirements:Broadband Internet connection
    • Additional:Quicktime Player is required for playing the videos
    Recommended:
    • Graphics:Laptop versions of these chipsets may work but are not supported. Updates to your video and sound card drivers may be required
    • Additional:Quicktime Player is required for playing the videos
There are no public reviews for this product yet
You can write your own review for this product to share your experience with the community. Use the area above the purchase buttons on this page to write your review.