This content requires the base game 嗜血印 Bloody Spell on Steam in order to play.

All Reviews:
Positive (30) - 86% of the 30 user reviews for this game are positive.
Release Date:
Jul 1, 2019
Developer:

Sign in to add this item to your wishlist, follow it, or mark it as not interested

English language not supported

This product does not have support for your local language. Please review the supported language list below before purchasing

Downloadable Content

This content requires the base game 嗜血印 Bloody Spell on Steam in order to play.

Buy BloodySpell dlc20003 猫咪制服诱惑

 

About This Content

Players can equip the cat's uniform temptation series in the jewelry, switch to sexy little wild cat for entertainment and battle.
The Dlc has four garments, namely: leopard underwear, cotton underwear, alternative prison uniforms, and tight leather.
Note: All of this Dlc content can be explored in-game.

Mature Content Description

The developers describe the content like this:

Sexy clothing, some exposed

System Requirements

    Minimum:
    • OS: Windows 7+
    • Processor: Intel i3 Processor
    • Memory: 4 GB RAM
    • Graphics: Nvidia GeForce GTX 560
    • DirectX: Version 9.0
    • Storage: 10 GB available space
    Recommended:
    • OS: Windows 7+
    • Processor: Intel i7 Processor
    • Memory: 8 GB RAM
    • Graphics: Nvidia GeForce GTX 770
    • DirectX: Version 11
    • Storage: 10 GB available space

More DLCs from this game

Customer reviews

Review Type


Purchase Type


Language


Date Range
To view reviews within a date range, please click and drag a selection on a graph above or click on a specific bar.

Show graph



Display As:
Show graph
 
Hide graph
 
Filters
Excluding Off-topic Review Activity
Playtime:
Loading reviews...