This content requires the base game Saints Row IV: Re-Elected on Steam in order to play.

All Reviews:
Mostly Positive (77) - 79% of the 77 user reviews for this game are positive.
Release Date:
Oct 29, 2013
Publisher:
Tags

Sign in to add this item to your wishlist, follow it, or mark it as ignored

Check out the entire Deep Silver franchise on Steam
Notice: Saints Row IV - The Super Saints Pack is no longer available on the Steam store.

Downloadable Content

This content requires the base game Saints Row IV: Re-Elected on Steam in order to play.

 

About This Content

It's hard to be a superhero, saving the world day in and day out while always wearing the same old clothes. Well not anymore! Fill your closet with an array of unforgivingly skin-tight costumes with the Super Saints Pack. Let Zinyak know that not only does the Head of State have superpowers but fashion sense too!

Mature Content Description

The developers describe the content like this:

This DLC may contain content not appropriate for all ages, or may not be appropriate for viewing at work: General Mature Content

System Requirements

Windows
SteamOS + Linux
    Minimum:
    • OS *: Windows Vista (x86 or x64)
    • Processor: Intel Core 2 Quad Q6600 | AMD Athlon II x3
    • Memory: 4 GB RAM
    • Graphics: NVIDIA GTX 260 | AMD Radeon HD 5800 series
    • DirectX: Version 10
    Recommended:
    • OS *: Windows 7 (x86 or x64)
    • Processor: Intel i3 2100T | AMD Phenom II x4 or higher
    • Memory: 4 GB RAM
    • Graphics: NVIDIA GTX 560 | AMD Radeon HD 6800 series or higher
    • DirectX: Version 11
* Starting January 1st, 2024, the Steam Client will only support Windows 10 and later versions.
    Minimum:
    • OS: Ubuntu 14.04.3 LTS or SteamOS Brewmaster
    • Processor: Intel Core i3-2100 (3.1 GHz) or AMD Athlon II X4 645 AM3 (3.1 GHz)
    • Memory: 4096 MB RAM
    • Graphics: GeForce GT 440 (1024 MB) or Radeon HD 6670 (1024 MB)
    • Additional Notes: Recommended Graphics Drivers: Nvidia: 352, 355 or 358 series driver / AMD: AMD Catalyst (fglrx) 15.9 or better. MESA drivers and Intel Graphics are not currently supported.
    Recommended:
    • OS: Ubuntu 14.04.3 LTS or SteamOS Brewmaster
    • Processor: Intel Core i5-2500K (3.3 GHz) or AMD FX-4300 (3.8 GHz)
    • Memory: 8192 MB RAM
    • Graphics: GeForce GTX 660 (2048 MB) or Radeon HD 6970 (2048 MB)
    • Additional Notes: Recommended Graphics Drivers: Nvidia: 352, 355 or 358 series driver / AMD: AMD Catalyst (fglrx) 15.9 or better. MESA drivers and Intel Graphics are not currently supported.

More DLCs from this game

More from Deep Silver

What Curators Say

2 Curators have reviewed this product. Click here to see them.

Customer reviews

Review Type


Purchase Type


Language


Date Range
To view reviews within a date range, please click and drag a selection on a graph above or click on a specific bar.

Show graph



Playtime
Filter reviews by the user's playtime when the review was written:


No minimum to No maximum
Display As:
Show graph
 
Hide graph
 
Filters
Excluding Off-topic Review Activity
Playtime:
Loading reviews...