This content requires the base game Total War: WARHAMMER II on Steam in order to play.

All Reviews:
Very Positive (356) - 82% of the 356 user reviews for this game are positive.
Release Date:
Dec 12, 2019

Sign in to add this item to your wishlist, follow it, or mark it as not interested

Check out the entire Total War Official franchise on Steam

Downloadable Content

This content requires the base game Total War: WARHAMMER II on Steam in order to play.

Download Total War: WARHAMMER II - Repanse de Lyonesse

 

About This Content



Repanse de Lyonesse, or the ‘Damoiselle de Guerre’ as she is known throughout Bretonnia, is a revered knight of the Chevaliers de Lyonesse. Armed with the mighty Sword of Lyonesse and fighting beside her trusty paladin companion, Henri Le Massif, she embodies the unrelenting crusading spirit of her brethren.

Leading the faction of Chevaliers de Lyonesse, Repanse wages a chivalric conquest across the Southlands to ensure the foul filth of the undead, Skaven, and Greenskins are cleansed from the deserted plains. A very powerful close-combat warrior, she has several unique skills granting her a range of bonuses including Physical Resistance and Melee Defence for her and her army.

Mature Content Description

The developers describe the content like this:

Gameplay consists of graphic and realistic-looking depictions of physical conflict, weapons and depictions of human injury and death.

System Requirements

Windows
Mac OS X
SteamOS + Linux
    Minimum:
    • OS: Windows 7 64Bit
    • Processor: Intel® Core™ 2 Duo 3.0Ghz
    • Memory: 5 GB RAM
    • Graphics: NVIDIA GTX 460 1GB | AMD Radeon HD 5770 1GB | Intel HD4000 @720p
    • DirectX: Version 11
    • Storage: 60 GB available space
    Recommended:
    • OS: Windows 7 / 8 (8.1)/ 10 64Bit
    • Processor: Intel® Core™ i5-4570 3.20GHz
    • Memory: 8 GB RAM
    • Graphics: NVIDIA GeForce GTX 770 4GB | AMD Radeon R9 290X 4GB @1080p
    • DirectX: Version 11
    • Storage: 60 GB available space
    Minimum:
    • OS: macOS 10.14
    • Processor: 2.0GHz Intel Core i5 or better
    • Memory: 8 GB RAM
    • Graphics: 2GB Nvidia 680MX, 2GB AMD R9 M290, 1.5GB Intel Iris Graphics 540 or better (see notes for more details)
    • Storage: 60 GB available space
    • Additional Notes: The game is officially supported on the following Macs. To check your Mac model and when it was released, select About This Mac from the Apple menu on your menu bar.
      • * All 13" MacBook Pros released since 2016
      • * All 15" MacBook Pros released since Late 2013 with a 2.3GHz processor or better
      • * All 21.5" iMacs released since Late 2017
      • * All 27" iMacs released since Late 2013 with a 2GB graphics card or better (1)
      • * All 27" iMac Pros released since Late 2017
      • * All Mac Pros released since Late 2013
      • 1. Late 2012 models with a 2GB Nvidia 680MX graphics card are also supported.
      Please note for your computer to meet the minimum requirements it must match or better all elements of the listed spec. For more detailed specifications check the Feral website. ———
        The following Macs are capable of running the game but do not consistently meet the standards required for official support.
      • * All 15" MacBook Pros released since Late 2013
      • * All 21.5" iMacs released since Late 2013 with a 2.7GHz processor or better.
    Minimum:
    • OS: Ubuntu 18.04 64-bit
    • Processor: 3.4GHz Intel Core i3-4130
    • Memory: 6 GB RAM
    • Graphics: 2GB Nvidia GTX 680 or better, 2GB AMD R9 285 (GCN 3rd Gen) or better
    • Storage: 60 GB available space
    • Additional Notes:
      • * Requires Vulkan
      • * Nvidia graphics cards require driver version 396.54 (tested)
      • * AMD GPU's require Mesa 18.1.5 or better (tested)
      • * Intel GPU's are not supported at time of release
    Recommended:
    • OS: Ubuntu 18.04 64-bit
    • Processor: 3.4 GHz Intel Core i7-4770
    • Memory: 8 GB RAM
    • Graphics: 4GB Nvidia 970, 4GB AMD RX 480
    • Storage: 60 GB available space
    • Additional Notes:
      • * Requires Vulkan
      • * Nvidia graphics cards require driver version 396.54 (tested)
      • * AMD GPU's require Mesa 18.1.5 or better (tested)
      • * Intel GPU's are not supported at time of release

More DLCs from this game

More from Total War Official

Customer reviews

Review Type


Purchase Type


Language


Date Range
To view reviews within a date range, please click and drag a selection on a graph above or click on a specific bar.

Show graph



Playtime
Filter reviews by the user's playtime when the review was written:


No minimum to No maximum
Display As:
Show graph
 
Hide graph
 
Filters
Excluding Off-topic Review Activity
Playtime:
Loading reviews...