This content requires the base game Rugby League Team Manager 2018 on Steam in order to play.

All Reviews:
No user reviews
Release Date:
Mar 21, 2018

Sign in to add this item to your wishlist, follow it, or mark it as not interested

Downloadable Content

This content requires the base game Rugby League Team Manager 2018 on Steam in order to play.

Download Rugby League Team Manager 2018 - Season 2018 Update

 

About This Content

Rugby League Team Manager 2018 Season Update!





This DLC features a full 2018 season upgrade for Rugby League Team Manager 2018. This update includes the new updated competition structure and fixtures.

  • Updated Super League teams, Squad lists + Stats and kits.
  • Updated Championship, Squad lists + Stats and kits.
  • Updated League One, Squad lists + Stats and kits.
  • Updated NRL teams, Squad lists + Stats and kits.
  • Updated NCL teams, Squad lists


If you purchase the 2018 Season DLC update, but still wish to play with your old saved games, please just untick the Installed checkbox in the DLC section of the Library page in Steam. To switch back to play with the 2018 Season DLC update, then please just tick the Installed checkbox.

Please note your old saved games created before the 2018 season update will not work with the new update, and any saved games created whilst playing with the new 2018 season update will not work or show up with the non-updated game

Also note:-
When you tick or untick the Installed check box in the DLC section of the Steam Library, it activates a download update.
So each time you tick or untick the Installed checkbox, you have to wait for the update to download.

External Researchers :- Dan Crowther and Kieran Wells

System Requirements

Windows
Mac OS X
    Minimum:
    • OS: Windows Vista
    • Processor: Intel Core 1.8Ghz+
    • Memory: 2 GB RAM
    • Graphics: DirectX 9.0c compliant
    • DirectX: Version 9.0c
    • Storage: 1 GB available space
    • Additional Notes: Minimum Resolution 1024x600. Please note, Mobile Intel(R) 45 Express Chipset Family is not supported
    Minimum:
    • OS: Mac OSX 10.8
    • Processor: Intel Core 1.8GHz
    • Memory: 2 GB RAM
    • Graphics: OpenGL 2.0 compliant
    • Storage: 1 GB available space
    • Additional Notes: Minimum Resolution 1024x600
There are no reviews for this product

You can write your own review for this product to share your experience with the community. Use the area above the purchase buttons on this page to write your review.