This content requires the base game Total War: MEDIEVAL II – Definitive Edition on Steam in order to play.

Sign in to add this item to your wishlist, follow it, or mark it as not interested

Check out the entire Total War Official franchise on Steam

Downloadable Content

This content requires the base game Total War: MEDIEVAL II – Definitive Edition on Steam in order to play.

 

System Requirements

Windows
Mac OS X
SteamOS + Linux
    Minimum System Requirements:
    • Microsoft® Windows® 2000/XP
    • Celeron 1.5GHz Pentium 4® (1500MHz) or equivalent AMD® processor
    • 512MB RAM
    • 11GB of uncompressed free hard disk space
    • 100% DirectX® 9.0c compatible 16-bit sound cardand latest drivers
    • 100% Windows® 2000/XP compatible mouse,keyboard and latest drivers
    • DirectX® 9.0c
    • 128MB Hardware Accelerated video card with Shader 1 support and the latest drivers. Must be 100% DirectX® 9.0c compatible
    • 1024 x 768 minimum display resolution
    • Internet (TCP / IP) play supported; Internet play requires broadband connection and latest drivers; LAN play requires Network card.
    Important Note: Some cards may not be compatible with the 3D acceleration features utilized by Medieval II: Total War. Please refer to your hardware manufacturer for 100% DirectX® 9.0c compatibility.
    OS: 10.10.5
    Processor: 1.8 GHz
    RAM: 4 GB
    Graphics: 256 MB
    Mac OS: 10.10.5
    Hard Disk: 32 GB
    Input: Keyboard & Mouse

    The following graphics cards are not supported: ATI X1xxx series, ATI HD2xxx series, Intel GMA series, NVIDIA 7xxx series and NVIDIA 8xxx series.
    OS: 10.11.2
    Processor: 2.4 GHz
    RAM: 4 GB
    Graphics: 512 MB
    Mac OS: 10.11.1
    Hard Disk: 32 GB
    Input: Multi-button Mouse

    The following graphics cards are not supported: ATI X1xxx series, ATI HD2xxx series, Intel GMA series, NVIDIA 7xxx series and NVIDIA 8xxx series.
    OS:
    Ubuntu 14.04
    Steam OS 2.0 (NVIDIA & Intel Only)
    Graphics Card:
    Nvidia 600 series+ with Driver Version 352.55
    AMD R7 with Mesa 11.2 driver*
    Intel Iris Pro with Mesa 11.2 driver*

    *IMPORTANT: AMD GPUS may require Ubuntu 15.10 or later. Mesa 11.2 driver still in active development.
    OS:
    Ubuntu 15.10
    Steam OS 2.0 (NVIDIA & Intel Only)
    Graphics Card:
    Nvidia 700 series+ with Driver Version 352.55
    AMD R9 with Mesa 11.2 driver*

    *IMPORTANT: AMD GPUS may require Ubuntu 15.10 or later. Mesa 11.2 driver still in active development.

More from Total War Official

There are no reviews for this product

You can write your own review for this product to share your experience with the community. Use the area above the purchase buttons on this page to write your review.