Om dit spel te kunnen spelen moet je het originele spel Young Justice: Legacy hebben.

Releasedatum: 19 nov 2013
Populaire tags van gebruikers voor dit product:

Log in om dit spel aan je verlanglijst toe te voegen of om deze als niet interessant te markeren

Downloadbare inhoud

Om dit spel te kunnen spelen moet je het originele spel Young Justice: Legacy hebben.

Young Justice: Legacy - Covert Costume Pack kopen

 

Over deze content

Geef je helden een nieuw uiterlijk met twaalf undercoverkostuums voor je hele team. Verras je tegenstanders!

Systeemeisen

    Minimum:
    • OS: Windows XP
    • Processor: 2Ghz Dual Core
    • Memory: 2 GB RAM
    • Graphics: NVidia GeForce 6800 or ATI Radeon x1950 or better with 256MB VRAM
    • DirectX: Version 9.0c
    • Network: Broadband Internet connection
    • Hard Drive: 3 GB available space
Er zijn geen openbare recensies voor dit product in je taal
Je kunt je eigen recensie voor dit product schrijven om je ervaring met de community te delen. Gebruik het gebied boven de aankoopknoppen op deze pagina om je recensie te schrijven.