Elder Sign: Omens is a digital version of the popular board game by Fantasy Flight Games. Build a team of unique investigators and fight to keep an all-powerful Ancient One from invading our world! Explore museums, oceans, deserts and more for the arcane Elder Signs that will help seal the Ancient One away.
全部评测:
多半好评 (188) - 188 篇用户的游戏评测中有 78% 为好评。
发行日期:
2011年10月31日

想要将这件物品添加至您的愿望单、关注它或标记为不感兴趣,请先登录

不支持简体中文

本产品尚未对您目前所在的地区语言提供支持。在购买请先行确认目前所支持的语言。

购买 Elder Sign: Omens

 

最新更新 查看所有(8)

7月24日

Fixed VSync problem

- Fixed issue where VSync wasn't properly functioning.
1 条留言 了解更多

6月15日

Reverting Linux Build

Due to some issues with the latest update, we are reverting the Linux version to the latest release prior to the update.
1 条留言 了解更多

评测

“Game of the Week”
G4 TV

“Cthulhu Approved”
4.5/5 – Touch Arcade

“The presentation here, like most of Fantasy Flight’s productions, is beyond top notch.”
4.5/5 – Gamezebo

关于这款游戏

Elder Sign: Omens is a digital version of the popular board game by Fantasy Flight Games. Build a team of unique investigators and fight to keep an all-powerful Ancient One from invading our world! Explore museums, oceans, deserts and more for the arcane Elder Signs that will help seal the Ancient One away.

Greenlit by the Steam community, the award-winning mobile game Elder Sign: Omens is now available for Steam. This package includes all of the content from the mobile game including the premium paid expansion content.

Key Features

  • All downloadable expansion content included in a single package
  • Over 30 different investigators, each with their own unique ability
  • Over 200 adventures spread across the world
  • 7 Different Ancient Ones with varying degrees of difficulty

系统需求

Windows
Mac OS X
SteamOS + Linux
    最低配置:
    • 操作系统: Windows® XP SP3
    • 处理器: 1.5 Ghz Dual Core Processor
    • 内存: 1 GB RAM
    • 图形: 2.0 Pixel Shader w/ 256 MB of VRAM
    • DirectX 版本: 9.0
    • 存储空间: 需要 2 GB 可用空间
    最低配置:
    • 操作系统: OS X Snow Leopard (10.6.8) or better
    • 处理器: 1.5 Ghz Dual Core Processor
    • 内存: 1 GB RAM
    • 图形: 2.0 Pixel Shader Compatible w/ 256 MB of VRAM
    • 存储空间: 需要 2 GB 可用空间
    最低配置:
    • 操作系统: Ubuntu 12.04 or 13.10
    • 处理器: 1.5 Ghz Dual Core Processor
    • 内存: 1 GB RAM
    • 图形: 2.0 pixel shader compatible w/ 256 MB of VRAM
    • 存储空间: 需要 2 GB 可用空间
    • 附注事项: Linux support is considered beta. Some features may not function properly (such as Fullscreen).
消费者评测 了解更多
High Volume of Reviews Detected:
Exclude  or  View Only
评测结果


购得方式


语言


日期范围
To view reviews within a date range, please click and drag a selection on a graph above or click on a specific bar.

Show graph



显示:
Show graph
 
Hide graph
 
Filters
Showing 3 reviews that match the filters above
无其他评测符合上述筛选条件
调整上方筛选条件以查看其它评测
加载评测中…