This content requires the base game Train Simulator on Steam in order to play.

All Reviews:
Positive (21) - 80% of the 21 user reviews for this game are positive.
Release Date:
Oct 1, 2009
Developer:

Sign in to add this item to your wishlist, follow it, or mark it as not interested

Downloadable Content

This content requires the base game Train Simulator on Steam in order to play.

Buy US Loco & Asset Pack

 

About This Content

The USA Loco and Asset Pack is aimed at users creating and using independently developed content for Train Simulator. If you install a route created by an external (third party) developer, they may specify that you require this asset pack in order to use their product.

This pack includes trackside detailing, trees and foliage, buildings, passengers and animals, as well as a number of US locomotives.

Please note: This pack does not include any ready-to-drive routes but all locomotives included are Quick Drive compatible, giving you the freedom to drive the locomotives on any Quick Drive enabled route for Train Simulator, such as those available through Steam.

If you have Railworks or Train Simulator 2012, you already have the contents of this pack.

Assets included

  • ES44AC, SD40-2 and EMD F7 diesel locomotives
  • Assorted passenger and freight wagons
  • Railroad tracks, fences and highways
  • Railroad signals, bridges and tunnels
  • Trees and foliage
  • Industrial and commercial buildings, houses and railroad buildings
  • People, animals and automobiles
  • North American ground textures
  • Sound effect domes

System Requirements

    Minimum:
    • OS:Windows® Vista / 7 / 8
    • Processor:Processor: 2.8 GHz Core 2 Duo (3.2 GHz Core 2 Duo recommended), AMD Athlon MP (multiprocessor variant or comparable processors)
    • Memory:2 GB RAM
    • Graphics:512 MB with Pixel Shader 3.0 (AGP PCIe only)
    • DirectX®:9.0c
    • Hard Drive:6 GB HD space
    • Sound:Direct X 9.0c compatible
    • Other Requirements:Broadband Internet connection
    • Additional:Quicktime Player is required for playing the videos
    Recommended:
    • Additional:Quicktime Player is required for playing the videos
Customer reviews
High Volume of Reviews Detected:
Exclude  or  View Only
Review Type


Purchase Type


Language


Date Range
To view reviews within a date range, please click and drag a selection on a graph above or click on a specific bar.

Show graph



Display As:
Review Beta NEW!
When enabled, will sort reviews by new Helpfulness score. Read more about it in the blog post.
Show graph
 
Hide graph
 
Filters
Review Helpfulness Beta Enabled
Loading reviews...