このコンテンツをプレイする為にはベースとなる Babel Rising がSteam上に必要です。

ユーザーレビュー: 好評 (1 件のレビュー)
リリース日: 2012年8月7日
ユーザーが定義したこの製品への人気タグ:

このアイテムをウィッシュリストへの追加、フォロー、興味なしとチェックするには、サインインしてください。

ダウンロードコンテンツ

このコンテンツをプレイする為にはベースとなる Babel Rising がSteam上に必要です。

Babel Rising - DLC を購入する

 

このコンテンツについて

Sky’s the Limit adds additional content that will test your almighty powers in your quest to thwart mankind from constructing the Tower of Babel. Unleash your wrath and command the elements to defeat your targets and defend your reign over Babylon!

Key Features:

  • Punish the unyielding strong worker, tougher than his weaker counterparts, with your unforgiving elemental attacks. He’ll continue to build until you can defeat him!
  • Inhibit the slave master – strategically positioned next to the tower – from using his whip to accelerate the speed in which workers climb the stairs to the top.
  • Your patience is tested when you encounter a new kind of priest, who changes his protections every few seconds, avoiding the elemental assaults you throw in his direction.
  • Move beyond three existing towers and unleash your destruction to overcome challenges on two all-new towers: the Ishtar Gate and the Heathen Statue.
  • Enjoy competitive and cooperative multiplayer modes.

システム要件

Windows
Mac OS X
    Minimum:
    • OS: Windows® XP (SP3), Windows® Vista (SP2), Windows® 7 (SP1)
    • Processor: 3.4 GHz Intel® Pentium® D 945 or AMD® Athlon™ 64 X2 3800+ 2.0Ghz or faster
    • Memory: 1 GB Windows XP / 1.5 GB Windows® Vista, Windows® 7
    • Graphics: 128 MB DirectX® 9.0-compliant card with Shader Model 3.0 or higher (see supported list)
    • DirectX®: 9.0
    • Hard Drive: 500 MB or more
    • Sound: DirectX® 9.0 compatible
    • Supported Video Cards at Time of Release:
      ATI Radeon HD 2600XT / 3000 / 4000 / 5000 / 6000 / 7000 series
      Nvidia GeForce 7600GS / 8 / 9 / 100 / 200 / 400 / 500 / 600 series
      Laptop versions of these cards may work but are NOT supported. These chipsets are the only ones that will run this game.
    Recommended:
    • OS: Windows® XP SP3, Windows® Vista SP2, Windows® 7 SP1
    • Processor: 2.4 GHz Intel® Core2Duo® E6600 or 2.5 GHz AMD® Athlon™ 64 X2 4800+ or faster
    • Memory: 2 GB Windows XP / Windows® Vista, Windows® 7
    • Graphics: 256 MB DirectX® 10.0-compliant card with Shader model 4.0 or higher (Radeon HD3870 or GeForce 8800GT or higher)
    • DirectX®: 9.0
    • Hard Drive: 1 GB
    • Sound: DirectX® 9.0 compatible
    Minimum:
    • OS: Mac® OS X Lion 10.7.4
    • Processor: Intel Core 2 Duo @ 2.53Ghz
    • Memory: 4 GB
    • Graphics: NVIDIA® GeForce® 9400 256MB
    • Hard Drive: 500 MB or more
    Recommended:
    • OS: Mac OS X Lion 10.7.4
    • Processor: 2.66 Ghz Intel Core i5
    • Memory: 4 GB
    • Graphics: AMD Radeon HD 4850 512 mb
    • Hard Drive: 1 GB Supported Video Cards at Time of Release:
      ATI Radeon HD 2600XT / 3000 / 4000 / 5000 / 6000 / 7000 series
      Nvidia GeForce 7600GS / 8 / 9 / 100 / 200 / 400 / 500 / 600 series
      Laptop versions of these cards may work but are NOT supported. These chipsets are the only ones that will run this game.
参考になったカスタマーレビュー
6 人中 4 人 (67%) がこのレビューが参考になったと投票しました
1人がこのレビューが面白いと投票しました
投稿日: 6月27日
English language not supported
This product does not have support for your local language. Please review the supported language list below before purchasing


Jolly store page! Pls fiks.
このレビューは参考になりましたか? はい いいえ 面白い